QEMU: problems with mouse and keyboard settings - virtualization

I'm running Windows 8 in QEMU KVM, and two things make it not very usable.
First: mouse is slow (it lags behind movement) and I see the most mouse. That means every time I move, first I see host mouse moving and then guest mouse slowly gets under it.
Second: keyboard doesn't handle holding keys well. So let's say I press 'a' for several seconds. Normally I would expect a's to be typed every x miliseconds. In QEMU, only one a is written at start, and only when I release the key, all others are written at once.
My configuration is:
<!--
WARNING: THIS IS AN AUTO-GENERATED FILE. CHANGES TO IT ARE LIKELY TO BE
OVERWRITTEN AND LOST. Changes to this xml configuration should be made using:
virsh edit Windows_8
or other application using the libvirt API.
-->
<domain type='kvm'>
<name>Windows_8</name>
<uuid>b0208dac-b52b-1c2f-99a0-464daa8028b1</uuid>
<memory unit='KiB'>8388608</memory>
<currentMemory unit='KiB'>8388608</currentMemory>
<vcpu placement='static'>4</vcpu>
<os>
<type arch='x86_64' machine='pc-i440fx-trusty'>hvm</type>
<boot dev='hd'/>
</os>
<features>
<acpi/>
<apic/>
<pae/>
</features>
<cpu mode='custom' match='exact'>
<model fallback='allow'>Haswell</model>
<vendor>Intel</vendor>
<feature policy='require' name='tm2'/>
<feature policy='require' name='est'/>
<feature policy='require' name='vmx'/>
<feature policy='require' name='osxsave'/>
<feature policy='require' name='smx'/>
<feature policy='require' name='ss'/>
<feature policy='require' name='ds'/>
<feature policy='require' name='vme'/>
<feature policy='require' name='dtes64'/>
<feature policy='require' name='abm'/>
<feature policy='require' name='ht'/>
<feature policy='require' name='acpi'/>
<feature policy='require' name='pbe'/>
<feature policy='require' name='tm'/>
<feature policy='require' name='pdcm'/>
<feature policy='require' name='pdpe1gb'/>
<feature policy='require' name='ds_cpl'/>
<feature policy='require' name='rdrand'/>
<feature policy='require' name='f16c'/>
<feature policy='require' name='xtpr'/>
<feature policy='require' name='monitor'/>
</cpu>
<clock offset='localtime'/>
<on_poweroff>destroy</on_poweroff>
<on_reboot>restart</on_reboot>
<on_crash>restart</on_crash>
<devices>
<emulator>/usr/bin/kvm-spice</emulator>
<disk type='block' device='disk'>
<driver name='qemu' type='raw' cache='none'/>
<source dev='/dev/sda'/>
<target dev='hda' bus='ide'/>
<address type='drive' controller='0' bus='0' target='0' unit='0'/>
</disk>
<controller type='usb' index='0'>
<address type='pci' domain='0x0000' bus='0x00' slot='0x01' function='0x2'/>
</controller>
<controller type='pci' index='0' model='pci-root'/>
<controller type='ide' index='0'>
<address type='pci' domain='0x0000' bus='0x00' slot='0x01' function='0x1'/>
</controller>
<interface type='network'>
<mac address='52:54:00:9f:53:97'/>
<source network='default'/>
<model type='rtl8139'/>
<address type='pci' domain='0x0000' bus='0x00' slot='0x03' function='0x0'/>
</interface>
<input type='tablet' bus='usb'/>
<input type='mouse' bus='ps2'/>
<input type='keyboard' bus='ps2'/>
<graphics type='vnc' port='-1' autoport='yes'/>
<sound model='ich6'>
<address type='pci' domain='0x0000' bus='0x00' slot='0x04' function='0x0'/>
</sound>
<video>
<model type='vga' vram='65536' heads='1'/>
<address type='pci' domain='0x0000' bus='0x00' slot='0x02' function='0x0'/>
</video>
<memballoon model='virtio'>
<address type='pci' domain='0x0000' bus='0x00' slot='0x05' function='0x0'/>
</memballoon>
</devices>
</domain>
I have tried all types of mouse: PS/2, touchpad and USB.
Is it a common problem and is there some solution?
Maybe some guest drivers? (But I have only found too difficult tutorials to install Spice, so if you know about understandable one, please point me to it)
Thanks for any useful advice.

I don't think it is strictly related to QEMU as it may be a problem between QEMU and especially Windows.
Please see this article, it helped me fixing a similar problem few weeks ago.

Related

Phonegap 3.0 IOS plugins not found

I´m getting this error in XCode:
2013-08-23 14:36:18.284 Tell The DJ[14955:c07] ERROR: Plugin 'Device' not found, or is not a CDVPlugin. Check your plugin mapping in config.xml.
2013-08-23 14:36:18.284 Tell The DJ[14955:c07] -[CDVCommandQueue executePending] [Line 116] FAILED pluginJSON = [
"Device1096677259",
"Device",
"getDeviceInfo",
[
]
]
2013-08-23 14:36:18.285 Tell The DJ[14955:c07] CDVPlugin class CDVConnection (pluginName: NetworkStatus) does not exist.
2013-08-23 14:36:18.285 Tell The DJ[14955:c07] ERROR: Plugin 'NetworkStatus' not found, or is not a CDVPlugin. Check your plugin mapping in config.xml.
2013-08-23 14:36:18.285 Tell The DJ[14955:c07] -[CDVCommandQueue executePending] [Line 116] FAILED pluginJSON = [
"NetworkStatus1096677260",
"NetworkStatus",
"getConnectionInfo",
[
]
]
I installed Phonegap 3.0 with the Command Line Interface and paste my www files into the project folders. The app works fine but when i come to native functions like device ID, camera, network connections it fails and gets me this error. But I think my config.xml is right?
<?xml version='1.0' encoding='utf-8'?>
<widget id="io.cordova.helloCordova" version="2.0.0" xmlns="http://www.w3.org/ns/widgets">
<name>Hello Cordova</name>
<description>
A sample Apache Cordova application that responds to the deviceready event.
</description>
<author email="dev#cordova.apache.org" href="http://cordova.io">
Apache Cordova Team
</author>
<content src="index.html" />
<feature name="LocalStorage">
<param name="ios-package" value="CDVLocalStorage" />
</feature>
<access origin="http://dev.tellthedj.de" />
<preference name="KeyboardDisplayRequiresUserAction" value="true" />
<preference name="SuppressesIncrementalRendering" value="false" />
<preference name="UIWebViewBounce" value="true" />
<preference name="TopActivityIndicator" value="gray" />
<preference name="EnableLocation" value="false" />
<preference name="EnableViewportScale" value="false" />
<preference name="AutoHideSplashScreen" value="true" />
<preference name="ShowSplashScreenSpinner" value="true" />
<preference name="MediaPlaybackRequiresUserAction" value="false" />
<preference name="AllowInlineMediaPlayback" value="false" />
<preference name="OpenAllWhitelistURLsInWebView" value="false" />
<preference name="BackupWebStorage" value="cloud" />
<preference name="orientation" value="portrait" />
<preference name="webviewbounce" value="false" />
<preference name="prerendered-icon" value="true" />
<preference name="phonegap-version" value="3.0.0" />
<preference name="fullscreen" value="false" />
<preference name="stay-in-webview" value="false" />
<preference name="android-minSdkVersion" value="7" />
<preference name="android-installLocation" value="internalOnly" />
<preference name="target-device" value="universal" />
<preference name="autohide-splashscreen" value="true" />
<preference name="load-url-timeout" value="60000" />
<preference name="show-splashscreen-spinner" value="true" />
<preference name="show-splash-screen-spinner" value="true" />
<preference name="allow-inline-media-playback" value="false" />
<preference name="launch-mode" value="standard" />
<feature name="Media">
<param name="ios-package" value="CDVSound" />
</feature>
<feature name="Camera">
<param name="ios-package" value="CDVCamera" />
</feature>
<feature name="Console">
<param name="ios-package" value="CDVLogger" />
</feature>
<feature name="Device">
<param name="ios-package" value="CDVDevice" />
</feature>
<feature name="Notification">
<param name="ios-package" value="CDVNotification" />
</feature>
<feature name="File">
<param name="ios-package" value="CDVFile" />
</feature>
<feature name="FileTransfer">
<param name="ios-package" value="CDVFileTransfer" />
</feature>
<feature name="Geolocation">
<param name="ios-package" value="CDVLocation" />
</feature>
<feature name="Capture">
<param name="ios-package" value="CDVCapture" />
</feature>
<feature name="NetworkStatus">
<param name="ios-package" value="CDVConnection" />
</feature>
<feature name="SplashScreen">
<param name="ios-package" value="CDVSplashScreen" />
</feature>
<plugins>
<plugin name="Device" value="CDVDevice" />
</plugins>
</widget>
I was using PhoneGap 3.0/3.1 and was removing the local build folder before rebuilding (since I had to copy icons and stuff in a secondary build script). This broke my plugins and produced this same error message.
In the end I found I had to remove ./plugins/ios.json when removing ./platforms/ios to make sure the plugins were rebuilt.
Deleting the platforms/ios folder is not a solution for me as all manual customizations to the xcode project will be lost.
But there is a simple way around:
In XCode, goto Build Phases -> open the Compiled Sources dropdown.
Click + and add the missing plugin .m file that should be in your
Plugins directory (but is missing from the compiled sources).
This solution came from another stack overflow answer, here: https://stackoverflow.com/a/21148428/80254
Another alternative:
In xcode make sure the source files of the plugin has the 'target membership' settings set: In File-Explorer go to Plugins > CDVDevice.m and check if there is a tick next to your app name at "target membership" on the right side of xcode window. This actually does the same as the other solution but is a bit more convenient.
From here: https://stackoverflow.com/a/20576744/80254
I encountered the same issue. I have followed the solution given by Jeffrey Van Alstine. This is my script for building and testing an iOS app developed using Phonegap 3.0/3.1.
#!/bin/bash
echo "Killing xcode..."
kill $(ps aux | grep 'Xcode' | awk '{print $2}')
rm -r platforms/ios
rm plugins/ios.json
phonegap build ios
open platforms/ios/*.xcodeproj
Save it as a bash file, for example, ios.sh into your working directory (directory that contains www folder) and run ./ios.sh
This seems to be a known issue for 3.* versions
https://issues.apache.org/jira/browse/CB-4971
you can solve this by upgrading Phonegap to release 3.4.
Try reinstalling the plugin:
phonegap local plugin add https://git-wip-us.apache.org/repos/asf/cordova-plugin-device.git
I use Cordova 3.7 and I solved the problem with Kobkrit Viriyayudhakorn 's solution, BUT of course you need to use
cordova build ios
instead of
phonegap build ios
i think you need to use the correct config.xml
for me, it is Xcode project target folder config.xml, and not platform www folder
I have found a solution that worked for me. I was using with the Compass plugin and after adding the plugin I have noticed that the config.xml (plugin docs) says it should have
<feature name="Compass">
<param name="ios-package" value="**CDVLocation**" />
</feature>
while the ios.json in plugin has added
"config.xml": {
"/*": {
"<feature name=\"Compass\"><param name=\"ios-package\" value=\"**CDVCompass**\" /></feature>": 1,
"<feature name=\"Device\"><param name=\"ios-package\" value=\"CDVDevice\" /></feature>": 1
}
One of then refers to CDVCompass while the other CDVLocation ... changing the xml to CDVCompass did the trick and now the app is working.
I am so tired of removing and re-adding platforms for plugin issues! It seems like it is still a problem even now (2014/10) where if you add plugins to an app after adding platforms the plugin sometime does not get propagated down to the corresponding platform folders/etc. Note this seems to mainly affect iOS - not Android.
I think my solution is just an updated method of doing same thing bjunix posted earlier - but in XCode 6 to fix this sort of thing without removing/re-adding my platform I:
Expand my App/Plugins folder in the left project navigator panel
Click on each plugin file in the list that is currently in red text (one at time)
Jump to the right side (Utilities) panel and click the folder icon in the Identity and Type section to re-link it to the actual file (see screenshot below).
After doing the above my project finally builds.
When this happens, it seems the xcode npm package responsible for making changes to the pbxproj file sometimes leaves references to plugin files that have been removed. I have not tracked down under what exact circumstances this occurs, but it appears to happen from frequent plugin remove/add operations (to update a plugin for example).
I suspect that when a plugin is removed and the xcode npm package fails at its job, it is only able to remove the plugin file references from the PBXBuildFile section but no other sections, leaving the pbxproj in a broken state.
When the xcode npm package attempts to add the plugin file references again, it first checks if the references are already in pbxproj. It looks in the PBXFileReference section, and since it finds references to the plugin in there, aborts further processing, getting us nowhere.
My solution, albeit a hack when it comes down to it, is to force the xcode npm package to check the PBXBuildFile section instead. That section will be missing the references and in turn the plugin will be re-installed correctly.
Change pbxFileReferenceSection to pbxBuildFileSection on this line: https://github.com/alunny/node-xcode/blob/master/lib/pbxProject.js#L620
Re-install your plugins, and you should be good to go.
I my case After install Paypal Plugin I am facing issue.
I resolved its by add "PayPalMobileCordovaPlugin.m" in the Compile Source.
So you just need to add .m file in Compile source add it works for me.
Check Screenshot.
Hope its work for you
This can also happen if you have a plugin that is referenced but not installed. If you have tried the above solutions and can't find the referenced plugin's .m file it might be that the plugin isn't really installed.
I would check your plugins directory to be sure that there are files in it. If not, reinstall the plugin. I ran into this when I had a typo in the git repo when restoring plugins from the config.xml.
I resolved this issue by changing the "plugin" entry to a "feature" entry in the config.xml. (using PhoneGap 3.1/iOS). This is what the fix looked like:
<feature name="DGGeofencing">
<param name="ios-package" value="DGGeofencing"/>
</feature>
I solved this issue with complete reinstall of Node.js and Phonegap through the CLI Tool

Publishing to Flash 9/10 with Flash Professional CC

I recently upgraded to Flash Professional CC (Mac 10.8.4) and it no longer gives the option of saving to a version of Flash earlier than 10.3. But Google DoubleClick and other ad networks only allow versions up to 10.1. Some even restrict to version 9.
I tried following the directions for CS6 found in this thread Compile for Flash 10.1 in Flash Professional CS6
But when completed, the Target drop down box in Publish Settings does not list Flash 9 or 10.1.
In short recap, here's what I did:
Create folder path to /Users/[username]/Library/Application Support/Adobe/language/Configuration
Added folders for "ActionScript 3.0" and "Players" (after completed tasks, folders for "ActionsPanel", "Classes", and "Include" were created automatically)
In /ActionScript 3.0 folder, two subfolders ("FP9" and "FP10.1" containing the v9 and v10.1 playerglobal.swc files, respectively)
In /Players folder, inserted two files: "FlashPlayer9_0.xml" and "FlashPlayer10_1.xml". Here's the code of the v10.1 file, the v9 basically the same:
<?xml version="1.0" encoding="UTF-8"?>
<players>
<player id="FlashPlayer10.1" version="10" asversion="1">
<name>Flash Player 10.1</name>
<path builtin="true"/>
<path menuSortCategory="10"/>
<path platform="WIN">Device Central/adcdl.exe</path>
<path platform="MAC">Device Central/adcdl</path>
<playerDefinitionPath as2="$(UserConfig)/Classes/FP10;$(UserConfig)/Classes/FP9;$(UserConfig)/Classes/FP8;$(UserConfig)/Classes/FP7" as3="$(AppConfig)/ActionScript 3.0/FP10.1/playerglobal.swc" />
<feature name="multiScreenPublish" supported="true" />
<feature name="mobileAuthoringIntegration" supported="true" />
<feature name="deviceSound" supported="false"/>
<feature name="exportStreamingSound" supported="true"/>
<feature name="exportEventSound" supported="true"/>
<feature name="FSCommand2" supported="false"/>
<feature name="gradient_linearRGB" supported="true" />
<feature name="gradient_overflow" supported="true" />
<feature name="shape_strokeHint" supported="true" />
<feature name="shape_cap" supported="true" />
<feature name="shape_join" supported="true" />
<feature name="shape_mitre" supported="true" />
<feature name="shape_scale" supported="true" />
<feature name="linkage_exportForActionscript" supported="true" />
<feature name="linkage_exportForRuntimeSharing" supported="true" />
<feature name="linkage_exportInFirstFrame" supported="true" />
<feature name="linkage_importForRuntimeSharing" supported="true" />
<feature name="linkage_importAndAddToCache" supported="false" />
<feature name="publish_localPlaybackSecurity" supported="true" />
<feature name="publish_hardwareAcceleration" supported="true" />
<feature name="symbol_blendMode" supported="true" />
<feature name="actionScript_documentClass" supported="true" />
<feature name="symbol_blendMode" supported="true" />
<feature name="filters" supported="true" />
<feature name="component_binding" supported="true" />
<feature name="component_schema" supported="true" />
<feature name="screens" supported="true" />
<feature name="video" supported="true" />
<feature name="deviceVideo" supported="false"/>
<feature name="accessibility" supported="true" />
<feature name="dynamic_text_kerning" supported="true" />
<feature name="static_text_charwidth_nondeviceFont" supported="true" />
<feature name="static_text_charwidth_deviceFont" supported="true" />
<feature name="advanced_anti_alias_text" supported="true" />
<feature name="nine_slice_scaling" supported="true" />
<feature name="runtimeNumberMinMax" supported="true" />
<feature name="use8kSampleRate" supported="true" />
<feature name="useDefineFont4ForDeviceText" supported="true" />
<feature name="useDefineFont4ForEmbeddedFonts" supported="true" />
<feature name="textLayoutFramework" supported="true" />
<feature name="document_class" supported="true" />
<encodingPresets>
<preset uuid="da5cac1a-417a-4d86-b7f7-ef21010a5d7d" name="FLV - Match Source Attributes (High Quality)" ext="flv" default="true"/>
</encodingPresets>
<testmenu>
<menu name="ID_testInFlash" default="true"/>
<menu name="ID_testInDeviceCentral" />
</testmenu>
<debugmenu>
<menu name="ID_debugtInFlash" default="true"/>
<menu name="ID_debugInDeviceCentral"/>
</debugmenu>
</player>
</players>
Has anyone been able to get this to work on Flash Professional CC? I really appreciate any help you can give...
Ok, the issue here isn't that the tutorial isn't correct. The main difference is that Flash CS6 housed those folders in the
/Users/[username]/Library/Application Support/Adobe/language/Configuration
Folder while CC houses them in the Application Package itself. So follow the same tutorial but realize that everything is in the
/Applications/Adobe Flash CC/Adobe Flash CC.app/Contents/Common/Configuration/
Folder instead. Remember that to enter the Adobe Flash CC.app part you'll just need to right click the app in Finder and select "Show Package Contents" from the context menu.
Here are the directions:
Go to http://helpx.adobe.com/flash-player/kb/archived-flash-player-versions.html#playerglobal to download the Flash Player 10.1 playerglobal.swc file
Navigate to your /Applications/Adobe Flash CC/Adobe Flash CC.app/Contents/Common/Configuration/ActionScript 3.0 folder and create a new folder amongst the other FPxx.x folders named "FP10.1" and place your newly downloaded playerglobal.swc file in there. Note: The downloaded file is named playerglobal10_1.swc. Make sure to rename it to just playerglobal.swc.
Now head back to the ../Configurations folder (right outside of the ActionScript 3.0 folder) and go into your "Players" folder. There will be a number of XML files in here. Find the one named "FlashPlayer10_3.xml", dupilcate it and rename it to "FlashPlayer10_1.xml".
You'll need a text editor for this part. Open the newly duplicated file and change the references to "10.3" to "10.1" (a find/replace should do nicely here), save and you're done.
Restart Flash CC and you should have a new option in your export settings for "Flash Player 10.1".
If this doesn't work you may need to add the SWC to your Flash Movie. You can do that by opening Flash and:
Go to File >> ActionScript Settings
In the dialog box that pops up, there are three tabs in the middle. Select the second tab labeled "Library Path"
On that tab is a file listing tree that lists, SWC and ANE file locations associated with your Flash Movie or ActionScript file. Above that directory tree is a toolbar of buttons. The fourth button (which looks like a polaroid of the Flash Logo) will allow you to navigate to your SWC file to manually link it into your movie. Select that button, browse to your file and click "Open"
Click OK in Actionscript Settings to accept the changes.
Save your file, export again.
Please follow this blog post and look for kglad's response lower down. It explains exactly what to do to get flash player 9 working in Flash CC.
http://forums.adobe.com/message/5750996
I got it to show up on the list. You need to copy and paste from the flash 10.3 xml and modify the version info.. also modify the as3 line to point to the 10.1
I think that the code above was for cs6, must've been changed

Message Archiving Management on MongooseIM returning feature not implementing

I have edited the configuration file of MongooseIM as follows to enable MAM
{mod_mam_odbc_prefs, [pm]},
{mod_mam_odbc_arch, [pm]},
{mod_mam_odbc_user, [pm]},
{mod_mam, []}
After restarting the server, when i send a message it gets stored in the database tables of MAM (2 entries for each message which i don’t know why).
Now, when i send an IQ stanza to fetch these messages, i get “Feature Not Implemented” error in response.
IQ Sent:
<iq type=”get” id=”page1″ to=”exampleserver.com”><query xmlns=”urn:xmpp:mam:tmp”/></iq>
When i tried to discover the features using http://jabber.org/protocol/disco#info, i get the following response.
<feature var=”http://jabber.org/protocol/amp”/>
<feature var=”http://jabber.org/protocol/commands”/>
<feature var=”http://jabber.org/protocol/disco#info”/>
<feature var=”http://jabber.org/protocol/disco#items”/>
<feature var=”iq”/>
<feature var=”jabber:iq:last”/>
<feature var=”jabber:iq:register”/>
<feature var=”msgoffline”/>
<feature var=”presence”/>
<feature var=”presence-invisible”/>
<feature var=”urn:xmpp:carbons:1″/>
<feature var=”urn:xmpp:carbons:2″/>
<feature var=”urn:xmpp:mam:tmp”/>
<feature var=”urn:xmpp:ping”/>
<feature var=”urn:xmpp:sic:1″/>
<feature var=”vcard-temp”/>
You're addressing the IQ to exampleserver.com while you should either address it to bare JID of the sender (i.e. someuser#somedomain.com) or omit the to attribute completely - then the server will assume it's directed towards the sender's bare JID. Section 10.3.3 of RFC-6120 describes handling of IQs with or without the to attribute. The basic query example from XEP-0313 uses no to attribute in the IQ element.

How can I get hard drive to work for QEMU-virtualized Windows Home Server 2011?

I have configured a Windows Home Server 2011 guest with virt-install and virsh, but the windows installer can't find any hard drives. Nor can it load any virtio drivers for it.
This is my first qemu/kvm virtualization attempt, so maybe I'm just missing something obvious, but any help is appreciated! Here are the details:
I created the domain with virt-install 0.600.4.
The command:
virt-install --connect qemu:///system -n fas -r 6144 --vcpus=2 \
--disk pool=vmstore,size=50,bus=virtio,cache=none -c whs2011.iso --vnc \
--noautoconsole --os-type windows --os-variant win2k8 \
--network network=default,model=e1000 \
--disk path=virtio-win-0.1-74.iso,device=cdrom,perms=ro
I use os-variant win2k8, since no win2011 is available for virt-install, afaik. Don't know if this makes any trouble.
I did virsh destroy fas to stop it,
I modified it with virsh edit fas to add cdrom as first boot device.
The resulting xml for the domain is:
<domain type='kvm'>
<name>fas</name>
<uuid>3d170dbf-c96e-5b0c-0e75-0bd2d6c5e98c</uuid>
<memory unit='KiB'>6291456</memory>
<currentMemory unit='KiB'>6291456</currentMemory>
<vcpu placement='static'>2</vcpu>
<os>
<type arch='x86_64' machine='pc-i440fx-1.5'>hvm</type>
<boot dev='cdrom'/>
<boot dev='hd'/>
</os>
<features>
<acpi/>
<apic/>
<pae/>
</features>
<clock offset='localtime'/>
<on_poweroff>destroy</on_poweroff>
<on_reboot>restart</on_reboot>
<on_crash>restart</on_crash>
<devices>
<emulator>/usr/bin/kvm</emulator>
<disk type='file' device='disk'>
<driver name='qemu' type='raw' cache='none'/>
<source file='/var/lib/libvirt/images/fas.img'/>
<target dev='vda' bus='virtio'/>
<address type='pci' domain='0x0000' bus='0x00' slot='0x04' function='0x0'/>
</disk>
<disk type='file' device='cdrom'>
<driver name='qemu' type='raw'/>
<source file='/home/nb/whs2011.iso'/>
<target dev='hda' bus='ide'/>
<readonly/>
<address type='drive' controller='0' bus='0' target='0' unit='0'/>
</disk>
<disk type='file' device='cdrom'>
<driver name='qemu' type='raw'/>
<source file='/home/nb/virtio-win-0.1-74.iso'/>
<target dev='hdc' bus='ide'/>
<readonly/>
<address type='drive' controller='0' bus='1' target='0' unit='0'/>
</disk>
<controller type='usb' index='0'>
<address type='pci' domain='0x0000' bus='0x00' slot='0x01' function='0x2'/>
</controller>
<controller type='pci' index='0' model='pci-root'/>
<controller type='ide' index='0'>
<address type='pci' domain='0x0000' bus='0x00' slot='0x01' function='0x1'/>
</controller>
<interface type='network'>
<mac address='52:54:00:84:3b:8b'/>
<source network='default'/>
<model type='e1000'/>
<address type='pci' domain='0x0000' bus='0x00' slot='0x03' function='0x0'/>
</interface>
<serial type='pty'>
<target port='0'/>
</serial>
<console type='pty'>
<target type='serial' port='0'/>
</console>
<input type='tablet' bus='usb'/>
<input type='mouse' bus='ps2'/>
<graphics type='vnc' port='-1' autoport='yes'/>
<video>
<model type='vga' vram='9216' heads='1'/>
<address type='pci' domain='0x0000' bus='0x00' slot='0x02' function='0x0'/>
</video>
<memballoon model='virtio'>
<address type='pci' domain='0x0000' bus='0x00' slot='0x05' function='0x0'/>
</memballoon>
</devices>
</domain>
Then I started it again with virsh start fas and,
successfully connected to the view port with a vnc viewer.
The Windows installer was started and I clicked "New installation: Install Windows" (see http://i.stack.imgur.com/EaSnT.png).
Then I was presented with the fact that no hard drives could be found, so I clicked "Load drivers".
Then, no matter which folder I select from the virtio driver cd image, no hard drives show up when I hit OK (see http://i.stack.imgur.com/htoda.png).
My system is an up-to-date Ubuntu Server 13.10 (kernel 3.11.0-14-generic) running on an HP Proliant ML330 G6 (quad-core Intel Xeon #2.4GHz). QEMU version is 1.5.0.
Any input is welcome!
After asking on superuser.com, I found out how to solve this. Find the answer here: https://superuser.com/a/698751/286884

Browser is not working in my Blackberry Simulator

I am working on developing Blackberry application using PhoneGap framwork. I have executed the sample app using below link
http://wiki.phonegap.com/w/page/31930982/Getting%20Started%20with%20PhoneGap%20BlackBerry%20WebWorks
But browser is not working in my Simulator.I mean if I try to goto Google site I am getting below error
I tried following steps too
1)I have installed 'BlackBerry Email and MDS Services Simulators 4.1.2'
2)Run the MDS and Run my application
Even I am getting issue. Please advice!
Device details:
Windows OS,PhoneGap,BlackBerry Email and MDS Services Simulators 4.1.2,Simulator:9550,BlackBerry WebWorks SDK 2.3.1.5
Config.xml
<?xml version="1.0" encoding="UTF-8"?>
<!--
Widget Configuration Reference:
http://docs.blackberry.com/en/developers/deliverables/15274/
-->
<widget xmlns="http://www.w3.org/ns/widgets"
xmlns:rim="http://www.blackberry.com/ns/widgets"
version="1.0.0.0">
<name>Corperate Directory</name>
<access subdomains="false" uri="http://www.google.com"/>
<description>
A sample application written with Cordova.
</description>
<license href="http://opensource.org/licenses/alphabetical">
</license>
<!-- Cordova API -->
<feature id="blackberry.system" required="true" version="1.0.0.0" />
<feature id="org.apache.cordova" required="true" version="1.0.0" />
<feature id="blackberry.find" required="true" version="1.0.0.0" />
<feature id="blackberry.identity" required="true" version="1.0.0.0" />
<feature id="blackberry.pim.Address" required="true" version="1.0.0.0" />
<feature id="blackberry.pim.Contact" required="true" version="1.0.0.0" />
<feature id="blackberry.io.file" required="true" version="1.0.0.0" />
<feature id="blackberry.utils" required="true" version="1.0.0.0" />
<feature id="blackberry.io.dir" required="true" version="1.0.0.0" />
<feature id="blackberry.app" required="true" version="1.0.0.0" />
<feature id="blackberry.app.event" required="true" version="1.0.0.0" />
<feature id="blackberry.system.event" required="true" version="1.0.0.0"/>
<feature id="blackberry.widgetcache" required="true" version="1.0.0.0"/>
<feature id="blackberry.media.camera" />
<feature id="blackberry.ui.dialog" />
<!-- Cordova API -->
<access subdomains="true" uri="file:///store/home" />
<access subdomains="true" uri="file:///SDCard" />
<!-- Expose access to all URIs, including the file and http protocols -->
<access subdomains="true" uri="*" />
<icon rim:hover="false" src="resources/icon.png" />
<icon rim:hover="true" src="resources/icon.png" />
<rim:loadingScreen backgroundColor="#CFCFCF"
foregroundImage="resources/loading_foreground.png"
onFirstLaunch="true">
<rim:transitionEffect type="fadeOut" />
</rim:loadingScreen>
<content src="index.html" />
<rim:permissions>
<rim:permit>use_camera</rim:permit>
<rim:permit>read_device_identifying_information</rim:permit>
<rim:permit>access_shared</rim:permit>
<rim:permit>read_geolocation</rim:permit>
</rim:permissions>
</widget>
You probably need to whitelist google.com in your config.xml:
<?xml version="1.0" encoding="UTF-8"?>
<widget xmlns="http://www.w3.org/ns/widgets"
xmlns:rim="http://www.blackberry.com/ns/widgets"
version="1.0.0.0">
<name>commonPitfalls</name>
<access subdomains="false" uri="http://www.google.com"/>
</widget>
From: http://supportforums.blackberry.com/t5/Web-and-WebWorks-Development/Common-BlackBerry-WebWorks-development-pitfalls-that-can-be/ta-p/624712
Alternatively, instead of checking google.com, you could use the connection api that PhoneGap offers:
http://docs.phonegap.com/en/1.8.0/cordova_connection_connection.md.html#Connection
Or use an xhr to google.com (with the appropriate whitelisting in your config.xml) to see if you get a response that way instead of loading in a page.

Resources